summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorKeuin <[email protected]>2023-09-04 01:57:22 +0800
committerKeuin <[email protected]>2023-09-04 02:03:15 +0800
commit143014a91e695106d8383ed173c482b3b4519663 (patch)
tree717d8d34ce9a5857b0293f7fcf7ea9ba13199da7 /Cargo.toml
initial versionv0.1.0
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..0f8ca6a
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "tcpmux"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+clap = { version = "4.4", features = ["derive"] }
+serde = "1.0"
+serde_derive = "1.0"
+serde_json = "1.0"
+tokio = { version = "1.32", features = ["full"] }
+toml = "0.7.6"
+tracing = "0.1"
+tracing-subscriber = "0.3"