summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKeuin <[email protected]>2022-04-11 12:07:58 +0800
committerKeuin <[email protected]>2022-04-11 12:08:11 +0800
commita15c8f6b3658095eb50da4bd75da697e37dbe033 (patch)
treeef4ec60e5c80b3c9031d60fe7caff52b331eb3e8 /CMakeLists.txt
parentcdb0bdfc60481708ab1a9707c0e1e4458e6396bf (diff)
Implement bitmap and PPM serialization (with a demo program).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a5c54e5..b822baa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,11 +12,12 @@ set(CMAKE_VERBOSE_MAKEFILE on)
# main executable
-add_executable(rt main.cpp vec.h)
+add_executable(rt main.cpp vec.h bitmap.h)
+add_executable(image_output main_image_output.cpp vec.h bitmap.h)
# googletest
-add_executable(all_tests test.cpp)
+add_executable(all_tests test.cpp vec.h bitmap.h)
target_link_libraries(all_tests gtest_main)
include(FetchContent)