summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKeuin <[email protected]>2022-04-12 10:29:41 +0800
committerKeuin <[email protected]>2022-04-12 10:29:41 +0800
commit78a65f44df3d0109eddb2d6835adda0ed4d36859 (patch)
treea216d1d82553bc32c5c79bd5c5d1cd393282ba6b /CMakeLists.txt
parentbbc4620da0af1d3cf89b62c1df31ef172dbb0ebe (diff)
Add DEBUG macro for future usage.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b5a00d4..d07e6ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,7 @@ set(CMAKE_CXX_STANDARD 11)
set(CMAKE_CXX_STANDARD_REQUIRED True)
set(common_compiler_args "-Wall -Werror -Wno-unused -std=c++11 -pthread")
-set(CMAKE_CXX_FLAGS_DEBUG "${common_compiler_args} -g -ggdb -fsanitize=address")
+set(CMAKE_CXX_FLAGS_DEBUG "${common_compiler_args} -g -ggdb -fsanitize=address -DDEBUG")
set(CMAKE_CXX_FLAGS_RELEASE "${common_compiler_args} -O2")
set(CMAKE_VERBOSE_MAKEFILE on)