summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKeuin <[email protected]>2022-04-11 22:13:57 +0800
committerKeuin <[email protected]>2022-04-11 22:13:57 +0800
commit43714bd116945573e7e4c854445462afa7f9b1b4 (patch)
tree7570dd1ab5e0feb38e504b4a49f4e8d2d0774873 /CMakeLists.txt
parentf6661b0243cb359fb4929aee06d1247944f3d2dd (diff)
Implement ray3, timer and a simple viewport scanner.
Fix bitmap wrong pixel sequence. Remove default constructor of bitmap. Add pixel mixture method.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b822baa..b5a00d4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,12 +12,13 @@ set(CMAKE_VERBOSE_MAKEFILE on)
# main executable
-add_executable(rt main.cpp vec.h bitmap.h)
+add_executable(rt main.cpp vec.h bitmap.h ray.h)
add_executable(image_output main_image_output.cpp vec.h bitmap.h)
+add_executable(simple_scanner main_simple_scanner.cpp vec.h bitmap.h ray.h timer.h)
# googletest
-add_executable(all_tests test.cpp vec.h bitmap.h)
+add_executable(all_tests test.cpp vec.h bitmap.h ray.h)
target_link_libraries(all_tests gtest_main)
include(FetchContent)