summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKeuin <[email protected]>2022-09-17 03:26:47 +0800
committerKeuin <[email protected]>2022-09-17 03:26:47 +0800
commit29a9208364fc245432beb0846f014f47fd560fee (patch)
tree79ceec9be315ff8f57cf84c68cef8715fbbf9680 /CMakeLists.txt
parent3f0f7f72f0870ebbff13faa1b2c911de80fb7865 (diff)
Fix cmake 3.24 depreciated feature warning.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 41abd0d..22b29e8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,11 @@ set(CMAKE_CXX_FLAGS_RELEASE "${common_compiler_args} -O2")
set(CMAKE_VERBOSE_MAKEFILE on)
+# Avoid warning about DOWNLOAD_EXTRACT_TIMESTAMP in CMake 3.24:
+if (CMAKE_VERSION VERSION_GREATER_EQUAL "3.24.0")
+ cmake_policy(SET CMP0135 NEW)
+endif()
+
link_libraries(pthread)
link_libraries(atomic)