summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKeuin <[email protected]>2022-05-28 17:43:10 +0800
committerKeuin <[email protected]>2022-05-29 02:30:35 +0800
commit75be026646ecb6b4b252ba226361ab83c30e86b1 (patch)
tree72bdce679ac8fcef6620563407ca8aa4cb146234 /CMakeLists.txt
parent2690abc54b28a290bf57df51956e38488ea0dfee (diff)
debug flags were set incorrectly.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bfd5079..4784e8a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,7 @@ project(mobileqq_fp_cracker C)
set(CMAKE_C_STANDARD 11)
set(common_compiler_args "-Wall -Werror -Wno-unused")
-set(CMAKE_CXX_FLAGS_DEBUG "${common_compiler_args} -g -ggdb -fsanitize=address -DDEBUG")
+set(CMAKE_C_FLAGS_DEBUG "${common_compiler_args} -g -ggdb -fsanitize=address -DDEBUG")
set(CMAKE_C_FLAGS_RELEASE "${common_compiler_args} -O3 -DNDEBUG")
add_executable(fp_cracker main.c)