summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKeuin <[email protected]>2022-05-27 16:49:03 +0800
committerKeuin <[email protected]>2022-05-27 16:49:29 +0800
commit448649b8fa7a85db722377f6f744a4efe1d2a697 (patch)
treeed5f92848054b8a8a2c6846556b5049ae5ac2aa0 /CMakeLists.txt
Initial version (not threaded).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..5bdfa5a
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 3.0)
+project(mobileqq_fp_cracker C)
+
+set(CMAKE_C_STANDARD 99)
+
+set(common_compiler_args "-Wall -Werror -Wno-unused")
+set(CMAKE_CXX_FLAGS_DEBUG "${common_compiler_args} -g -ggdb -fsanitize=address -DDEBUG")
+set(CMAKE_C_FLAGS_RELEASE "${common_compiler_args} -O3 -DNDEBUG")
+
+add_executable(fp_cracker main.c)
+
+target_link_libraries(fp_cracker libtomcrypt.a) \ No newline at end of file