summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorKeuin <[email protected]>2024-02-24 02:46:28 +0800
committerKeuin <[email protected]>2024-02-24 03:06:16 +0800
commite670f5389171a7a124d990fe2093e1f9290eccfc (patch)
tree9c9b313db57159f019b2d4f5770ab7a2e1085fe5 /Cargo.toml
Initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..74ca1d3
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "daigunyun"
+version = "0.0.1"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+serde_derive = "1.0.197"
+serde = "1.0.197"
+toml = "0.8.10"
+anyhow = "1.0.80"
+tokio = { version = "1.36.0", features = ["full"] }
+axum = { version = "0.7.4", features = ["tracing"] }
+tracing = "0.1.40"
+tracing-subscriber = { version = "0.3.18", features = ["env-filter"] }
+sqlx = { version = "0.7.3", features = ["sqlite", "runtime-tokio"] }
+futures-util = "0.3.29"
+log = "0.4.20"